Page 1 of 1

[Save2FTP] FTP upload never completes

Posted: 17 Feb 2010, 15:12
by skribb
Hi

I have a problem with the FTP upload. It is sporadic in nature. It usually works, but sometimes, it just stops and never completes. I can't even pause or abort the task, it will ignore those commands. If I restart the program, I can execute the task fine. I tried APBackUp a while and I'm experiencing the same stuff there too. What could be wrong?

I know it's not my FTP server, because I can't see any connection attempts in the server log.


Code: Select all

2010-02-17 16:01:38:[1001][I] Copying has started to FTP:  "[censored]"
2010-02-17 16:01:38:[1001][I] The archiving will be executed - files for archiving are available
2010-02-17 16:01:38:[1001][I] Task started

Re: [Save2FTP] FTP upload never completes

Posted: 17 Feb 2010, 19:41
by support
Usually the reason is a firewall between your host and FTP server. Try to use PASSIVE mode in Save2ftp.

Re: [Save2FTP] FTP upload never completes

Posted: 18 Feb 2010, 08:08
by skribb
Thanks.

I know you said usually, but I don't have a firewall. Anyway, gonna try PASSIVE and see what happens.

Re: [Save2FTP] FTP upload never completes

Posted: 25 Feb 2010, 14:19
by skribb
Tried passive mode and it doesn't work.

Shouldn't it be an application fault though? Since the app doesn't respond when I try to abort a task. And usually, the FTP server is able to respond even though the connection mode used is the wrong one. It should respond with an error message or something. But my FTP server records zero activity when Save2FTP allegedly "starts copying".

Re: [Save2FTP] FTP upload never completes

Posted: 26 Feb 2010, 10:08
by skribb
Update: I'm almost certain it's a bug now, because if I disable the automatic backup and just execute the task whenever I have new files to backup, the transfer works flawlessly. It only ever stops when the transfer is set to be automatic.